1007 Maximum Subsequence Sum
1007 Maximum Subsequence Sum
分数 25
全屏浏览
切换布局
作者 CHEN, Yue
单位 浙江大学
Given a sequence of K integers { N 1, N 2 , ..., N K }. A continuous subsequence is defined to be { N i , N i+1 , ..., N j} where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.
Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.
Input Specification:
Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.
Output Specification:
For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.
Sample Input:
10
-10 1 2 3 4 -5 -23 3 7 -21
Sample Output:
10 1 4
1.分析
1.题目要求如果全部为负数,那么最大和为0,输出数组的头和尾。
2.全部为负数 和 负数和0的组合是两回事,后者输出0 0 0;
2.代码
#include<iostream>
using namespace std;
const int MAX=1e5+10;
int K,a[MAX];
int s,ma,t,ts,e,f=0; //ma代表最大和,t代表局部最大值,s代表开始下标,ts代表局部开始下标,e代表结束下标
int main(){
cin>>K;
for(int i=0;i<K;i++){ //输入
cin>>a[i];
if(a[i]>=0) f=1; //判断是否全部为负数
}
for(int i=0;i<K;i++){
if(t+a[i]>a[i]){
t+=a[i];
}
else{
t=a[i];
ts=i;
}
if(t>ma){
ma=t;
e=i;
s=ts;
}
}
if(!f) cout<<ma<<" "<<a[0]<<" "<<a[K-1]; //判断输出
else if(f&&ma==0) cout<<ma<<" "<<0<<" "<<0;
else cout<<ma<<" "<<a[s]<<" "<<a[e];
return 0;
}