7-2 sdut-C语言实验-逆序建立链表
7-2 sdut-C语言实验-逆序建立链表
分数 20
全屏浏览
切换布局
作者 马新娟
单位 山东理工大学
输入整数个数N,再输入N个整数,按照这些整数输入的相反顺序建立单链表,并依次遍历输出单链表的数据。
输入格式:
第一行输入整数N;;
第二行依次输入N个整数,逆序建立单链表。
输出格式:
依次输出单链表所存放的数据。
输入样例:
10
11 3 5 27 9 12 43 16 84 22
输出样例:
22 84 16 43 12 9 27 5 3 11
#include<stdio.h>
#include<stdlib.h>
struct node
{
int data;
struct node *next;
};
int main()
{
int n;
struct node *head, *p;
head=(struct node*)malloc(sizeof(struct node));
//head->next=NULL;
scanf("%d",&n);
for(int i=0;i<n;i++)
{
p=(struct node*)malloc(sizeof(struct node));
scanf("%d",&p->data);
p->next=head->next;
head->next=p;
}
p=head->next;
while(p)
{
if(p->next==NULL)
printf("%d\n",p->data);
else
printf("%d ",p->data);
p=p->next;
}
return 0;
}
或者
#include<stdio.h>
#include<stdlib.h>
int main()
{
int i,j;
int *array=NULL;
scanf("%d",&i);
array=(int*)malloc(i*sizeof(int));
for(j=0;j<i;j++)
{
scanf("%d",&array[j]);
}
for(j=i-1;j>=0;j--)
{
if(j==i-1)
printf("%d",array[j]);
else
printf(" %d",array[j]);
}
return 0;
}