当前位置: 首页 > news >正文

A1062 PAT甲级JAVA题解 Talent and Virtue

About 900 years ago, a Chinese philosopher Sima Guang wrote a history book in which he talked about people's talent and virtue. According to his theory, a man being outstanding in both talent and virtue must be a "sage(圣人)"; being less excellent but with one's virtue outweighs talent can be called a "nobleman(君子)"; being good in neither is a "fool man(愚人)"; yet a fool man is better than a "small man(小人)" who prefers talent than virtue.

Now given the grades of talent and virtue of a group of people, you are supposed to rank them according to Sima Guang's theory.

Input Specification:

Each input file contains one test case. Each case first gives 3 positive integers in a line: N (≤105), the total number of people to be ranked; L (≥60), the lower bound of the qualified grades -- that is, only the ones whose grades of talent and virtue are both not below this line will be ranked; and H (<100), the higher line of qualification -- that is, those with both grades not below this line are considered as the "sages", and will be ranked in non-increasing order according to their total grades. Those with talent grades below H but virtue grades not are considered as the "noblemen", and are also ranked in non-increasing order according to their total grades, but they are listed after the "sages". Those with both grades below H, but with virtue not lower than talent are considered as the "fool men". They are ranked in the same way but after the "noblemen". The rest of people whose grades both pass the L line are ranked after the "fool men".

Then N lines follow, each gives the information of a person in the format:

ID_Number Virtue_Grade Talent_Grade

where ID_Number is an 8-digit number, and both grades are integers in [0, 100]. All the numbers are separated by a space.

Output Specification:

The first line of output must give M (≤N), the total number of people that are actually ranked. Then M lines follow, each gives the information of a person in the same format as the input, according to the ranking rules. If there is a tie of the total grade, they must be ranked with respect to their virtue grades in non-increasing order. If there is still a tie, then output in increasing order of their ID's.

Sample Input:

14 60 80
10000001 64 90
10000002 90 60
10000011 85 80
10000003 85 80
10000004 80 85
10000005 82 77
10000006 83 76
10000007 90 78
10000008 75 79
10000009 59 90
10000010 88 45
10000012 80 100
10000013 90 99
10000014 66 60

Sample Output:

12
10000013 90 99
10000012 80 100
10000003 85 80
10000011 85 80
10000004 80 85
10000007 90 78
10000006 83 76
10000005 82 77
10000002 90 60
10000014 66 60
10000008 75 79
10000001 64 90

核心思路: 根据德才分数对学生排名

        排名规则:  

                        德才全达到高分

                        德分达到高分

                        德分高于才分

                        剩余学生

                        德或才不达到最低分限制的学生

        四类分别按照总分排序,总分相同按照德分,德分相同按照学号

 

JAVA题解会导致时间受限

import java.util.Arrays;
import java.util.Comparator;
import java.util.Scanner;class Student {String id;int de, cai, sum;int flag;public Student(String id, int de, int cai) {this.id = id;this.de = de;this.cai = cai;this.sum = de + cai;}
}public class Main {public static void main(String[] args) {Scanner scanner = new Scanner(System.in);int n = scanner.nextInt();int L = scanner.nextInt();int H = scanner.nextInt();Student[] students = new Student[n];int m = 0; // 合格学生数量// 读取输入并分类学生for (int i = 0; i < n; i++) {String id = scanner.next();int de = scanner.nextInt();int cai = scanner.nextInt();students[i] = new Student(id, de, cai);if (de < L || cai < L) {students[i].flag = 5; // 不合格} else if (de >= H && cai >= H) {students[i].flag = 1; // 第一类} else if (de >= H && cai < H) {students[i].flag = 2; // 第二类} else if (de >= cai) {students[i].flag = 3; // 第三类} else {students[i].flag = 4; // 第四类}if (students[i].flag <= 4) {m++;}}// 过滤并复制合格学生到新数组Student[] validStudents = new Student[m];int idx = 0;for (Student s : students) {if (s.flag <= 4) {validStudents[idx++] = s;}}// 自定义排序Arrays.sort(validStudents, new Comparator<Student>() {@Overridepublic int compare(Student a, Student b) {if (a.flag != b.flag) {return a.flag - b.flag; // 类别升序} else if (a.sum != b.sum) {return b.sum - a.sum; // 总分降序} else if (a.de != b.de) {return b.de - a.de; // 德分降序} else {return a.id.compareTo(b.id); // 学号升序}}});// 输出结果System.out.println(m);for (Student s : validStudents) {System.out.printf("%s %d %d\n", s.id, s.de, s.cai);}scanner.close();}
}

C++可以解决:

#include<cstdio> 
#include<cstring>
#include<algorithm>
using namespace std;
struct Student{char id[10];int de,cai,sum;int flag;
}stu[1000010];bool cmp(Student a,Student b){if(a.flag!=b.flag) return a.flag<b.flag;else if(a.sum!=b.sum) return a.sum>b.sum;else if(a.de!=b.de) return a.de>b.de;//strcmp返回值小于0则a小于b else return strcmp(a.id,b.id)<0;
}int main(){int n,L,H;scanf("%d%d%d",&n,&L,&H);int m=n;for(int i=0;i<n;i++){scanf("%s%d%d",stu[i].id,&stu[i].de,&stu[i].cai);stu[i].sum=stu[i].de+stu[i].cai;if(stu[i].de<L||stu[i].cai<L){stu[i].flag=5;m--;}else if(stu[i].de>=H&&stu[i].cai>=H) stu[i].flag=1;else if(stu[i].de>=H&&stu[i].cai<H) stu[i].flag=2;else if(stu[i].de>=stu[i].cai) stu[i].flag=3;else stu[i].flag=4;}sort(stu,stu+n,cmp);printf("%d\n",m);for(int i=0;i<m;i++){printf("%s %d %d\n",stu[i].id,stu[i].de,stu[i].cai);}return 0;
} 

 

相关文章:

  • 大语言模型通过MCP控制STM32-支持Ollama、DeepSeek、openai等
  • 【C++】内存管理 —— new 和 delete
  • D. Explorer Space(dfs+剪枝)
  • 深入理解深度Q网络DQN:基于python从零实现
  • 三、c语言练习四题
  • 前端项目打包部署流程j
  • 无人机空中物流优化:用 Python 打造高效配送模型
  • 华为IP(6)
  • 中空电机在安装垂直轴高速电机后无法动平衡的原因及解决方案
  • 【网络】:传输层协议 —— UDP、TCP协议
  • Compose笔记(二十二)--NavController
  • 嵌入式硬件篇---SPI
  • 嵌入式硬件篇---陀螺仪|PID
  • 验证码与登录过程逻辑学习总结
  • Go语言——kratos微服务框架使用
  • Linux 进程控制 基础IO
  • 关系数据库-关系运算
  • Docker Compose 的历史和发展
  • C++ RAII机制
  • LeetCode 高频题实战:如何优雅地序列化和反序列化字符串数组?
  • 脑血管支架:救命神器还是定时炸弹?听听医生的大实话
  • 事关心脏健康安全,经导管植入式人工心脏瓣膜国家标准发布
  • 巴基斯坦全国航班仍持续延误或取消
  • 乘联分会:上半年车市价格竞争温和,下半年价格战或再开启
  • 耿军强任陕西延安市领导,此前任陕西省公安厅机场公安局局长
  • 上海市委常委会会议暨市生态文明建设领导小组会议研究基层减负、生态环保等事项